Mathematica 9 is now available

Workbench に関するQ&A

Q:Workbench はWolframのどの製品で使えるのですか.
Q:Workbenchを使うのに,インストールが必要なものはありませんか.
Workbench を使用するためには,Mathematica あるいは Workbench 対応の他のWolfram製品のインストールが必要です.
Q:Workbench にはどのような技術が使われているのでしょうか.
WorkbenchMathematicaEclipseの上に構築されています.Mathematica とJavaを透過的に接続する Mathematica ツールキットの J/Link を大いに利用するものです.
Q:Eclipseとは何ですか.
Eclipseは統合開発環境のための主導的なプラットフォームです.Eclipseはプラットフォーム非依存であり,プラグインとして知られるモジュールを含んだ拡張メカニズムを中心に構築されています.Eclipseには,さまざまなタスクを行うための無料・有料のプラグインが多数あります.これには,HTML,XML,UMLをはじめとする多数のWebテクノロジーの他,Java,C,C++,Fortran等の言語のサポートも含まれます.利用できるプラグインの詳細はEclipse Marketplaceでご覧ください.IBM,Nokia,Borland,Adobe等多数の企業が,Eclipseに基づいた技術を構築しています.
Q:Workbench はEclipseをどのように使っているのでしょうか.
Wolfram WorkbenchMathematica やその他のWolframテクノロジーのための多数のプラグインを含む,Wolfram版Eclipseということができます.Workbench のプラグインをスタンドアロンのEclipseにインストールすることもできます.プラグインだけが必要な場合は,Workbench のダウンロードプラットフォームを選ぶときに「Eclipse」を選んでください.Wolfram Workbench がEclipseの中核を使用するのと同じで,サードパーティのプラグインもEclipseでの場合と同じようにインストールされ実行されます.
Q:どのバージョンのEclipseがサポートされていますか.
Wolfram Workbench 2にはブランド化されたEclipse 3.5が含まれています.これは,既存のEclipse 3.4から3.8にインストールすることのできるプラグインとしても入手可能です.Eclipse 4.2は現在はサポートされていません.
Q:多言語の開発プロジェクトを実行しているのですが, Workbench でワークフローを管理できるでしょうか.
はい,Eclipseには幅広いプラグインがあるので,Workbench は多言語による開発に非常に適しています.
Q:Workbench はどのようなプラットフォームをサポートしていますか.
Workbench はWindows,Mac OS X,Linuxをサポートしています.
Q:どのバージョンの MathematicaWorkbench でサポートされていますか.
WorkbenchMathematica 6以降,およびそのいずれかのバージョンの Mathematica を含むWolfram製品がサポートされています.


Select Language: eneszh